Networking error across all products
Incident Report for Actionfigure Screen and Mobile
Resolved
After 33 minutes, CloudFlare has deployed a fix for all customers, and the TransitScreen web services are now accessible and fully operational again.

https://www.cloudflarestatus.com/incidents/tx4pgxs6zxdr
Posted Jul 02, 2019 - 10:18 EDT
Identified
CloudFlare, the DNS host and network proxy service for TransitScreen web products, is experiencing a major outage across North America. We are actively monitoring the situation.
Posted Jul 02, 2019 - 10:14 EDT
This incident affected: Actionfigure Screens.