Upstream vendor incident
Incident Report for Actionfigure Screen and Mobile
Resolved
All displays are running normally at this time.
Posted Sep 14, 2021 - 20:48 EDT
Update
Most affected displays are back up and running normally at this time. Our team is continuing the recovery process for the remainder.
Posted Sep 14, 2021 - 20:25 EDT
Update
The underlying cause has been fixed. Affected devices require individual attention to be restored to operation, and this process has begun.
Posted Sep 14, 2021 - 12:24 EDT
Identified
A significant number of TransitScreen customers are being affected by an incident at one of our upstream vendors. Although TransitScreen data services are running normally, the displays on site at some customer locations are not accessing and displaying that data. The underlying cause has been identified and we are working with the vendor to ensure recovery.
Posted Sep 14, 2021 - 11:08 EDT
This incident affected: Screen Professional, Plus, Premium.